WebSphere Commerce software requirements – Windows

WebSphere Commerce Version 7.0 software requirements on a Windows operating system.

Operating systems

32 bit and 64 bit kernel support for:

  • Microsoft Windows Server 2003 Standard Edition, Service Pack 2
  • Microsoft Windows Server 2003 Enterprise Edition, Service Pack 2
  • Microsoft Windows Server 2008 Datacenter Edition
  • Microsoft Windows Server 2008 Enterprise Edition
  • Microsoft Windows Server 2008 Standard Edition

WebSphere Application Server

The following 32 bit versions of WebSphere Application Server are supported:

  • WebSphere Application Server Network Deployment Version 7.0.0.3
  • WebSphere Application Server Base Version 7.0.0.3

Web servers

The following Web servers are supported:

  • IBM HTTP Server 7.0

Databases

32 and 64 bit support for:

  • WebSphere Commerce -  ExpressWebSphere Commerce Developer DB2 Universal Database Express Edition Version 9.5.4 ( recommend by me)
  • WebSphere Commerce EnterpriseWebSphere Commerce ProfessionalWebSphere Commerce Developer Oracle 11g Database version 11.1.0.7

Java tooling

  • Rational Software Architect Version 7.5.4
  • Rational Application Developer Version 7.5.4

Web browsers for WebSphere Commerce Tools

You can only access the WebSphere Commerce tools, like the Management Center or WebSphere Commerce Accelerator, from a supported browser on a machine running a Windows operating system on the same network as your WebSphere Commerce machine. In order to use the WebSphere Commerce tools, use one of the following browsers:
Management Center
  • Firefox 3.0
  • Microsoft Internet Explorer 7.0 and 8.0
WebSphere Commerce Accelerator
Microsoft Internet Explorer 7.0 and 8.0

Prior versions of these browsers do not support the full function of the WebSphere Commerce tools.

Web browsers for shoppers

The following browsers are supported for shoppers on the WebSphere Commerce starter stores:

  • Microsoft Internet Explorer 6.0, 7.0 and 8.0
  • Firefox 2.0 and 3.0
  • Safari 3

Directory servers

WebSphere Commerce can use these directory servers. See your directory server documentation for additional information.

  • Windows Active Directory 2003 and 2008
  • Lotus Domino Enterprise Directory Server 7.0 and 8.0
  • IBM Tivoli Directory Server 6.0, 6.1 and 6.2
  • Sun Java System Directory Server 6.0 and 6.1
  • Novell eDirectory 8.7.3 SP9 and 8.8.1

Other supported software

WebSphere Commerce supports, integrates with, or can connect to systems running the following additional software:

  • WebSphere  Commerce ProfessionalWebSphere Commerce Enterprise IBM Lotus Sametime Version 8.0
  • Edge Components 7.0
  • WebSphere Portal Server Version 6.1
  • IBM Eclipse Help System Version 3.4
  • IBM Support Assistant 4.0
  • WebSphere Commerce Developer IBM Installation Manager 1.3.2
  • InstallShield (Multi Platform Edition) – 5.0.3 Fix Pack AV
  • License Agreement Panel 2.6.2
  • LikeMinds 5.1
  • WebSphere Commerce EnterpriseWebSphere Commerce ProfessionalWebSphere Commerce Developer Lotus Expeditor 6.2
  • WebSphere MQ 6.0 (messaging server/client only)
  • WebSphere MQ 7.0 (messaging server/client only)
  • Lotus Connections 2.5
  • WebSphere Enterprise Service Bus 6.1
  • WebSphere Integration Developer 6.1
  • Flash 8
  • Flash 10 Player
  • IBM Tivoli License Manager
  • Languageware version 7.1.1
  • Taxware (Sales and Use Toolkit)
  • SAP CRM
  • IBM WebSphere sMash Version 1.1.1
  • WebSphere Commerce EnterpriseWebSphere Commerce ProfessionalWebSphere Commerce - Express VMware ESX/ESXi 3.5

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s